tema personalizado: el archivo .mo en inglés no funciona

4

Tengo un problema con un archivo .mo .

Tengo un tema personalizado localizado que funciona completamente en cuatro idiomas por el momento: holandés, inglés, francés y español. Hay un problema: la localización en inglés no funciona. Los otros idiomas funcionan bien.

El plugin de traducción es polylang. El complemento para crear los archivos .po y .mo es CodeStyling Localization.

Los archivos .po y .mo están ubicados en la carpeta /language/ dentro de mi tema.

El tema está localizado y funciona bien en holandés (idioma predeterminado), francés y español. Sin embargo, cuando estoy en la versión en inglés del sitio web, las palabras en holandés predeterminadas aparecen en cadenas localizadas.

He intentado eliminar los archivos .mo y .po en inglés y volver a crearlos, pero esto no ayudó. No es un problema con los archivos en_US.po o en_US.mo . Los copié del servidor del sitio y los probé en otra instalación de WP. Funcionó bien.

Me he quedado sin ideas. ¿Alguien tiene alguna sugerencia? ¿Hay alguna manera de probar la llamada al archivo .mo en inglés y obtener algunos comentarios de PHP? Cualquier idea es bienvenida.

    
pregunta Peter-L 16.12.2013 - 21:19

1 respuesta

0

Mis sugerencias:

  1. Verifique el idioma de la configuración de wordpress, debe ser holandés.
  2. Deshabilite el complemento simplemente cargue los archivos .mo en /languages/ .
  3. ¡Debes revisar tu tema! ¡Tal vez el problema sea reemplazar el idioma predeterminado! o ...
respondido por el Mohamad 22.11.2017 - 21:09

Lea otras preguntas en las etiquetas