Carga de medios fallida: "El archivo cargado solo se cargó parcialmente".

4

Estoy ejecutando Linux CentOS 5.8 y tengo mis páginas web con WordPress 4.0.

Estoy intentando subir fotos jpg al servidor a través de WordPress, pero falla al azar. Subí algunas fotos y luego recibo errores como:

“4.JPG” has failed to upload due to an error
The uploaded file was only partially uploaded.

Luego lo intento una y otra vez y otra vez hasta que se carga con éxito. Muy frustrante.

¿Cómo puedo depurar esto? ¿Hay un archivo de registro? ¿Dónde buscar?

    
pregunta Danijel 29.01.2015 - 14:56

4 respuestas

0

Logré resolver este problema cambiando la configuración del servidor Apache: hay un indicador KeepAlive que debe estar apagado.

Más sobre esta bandera:

Optimización de Apache: ¿KeepAlive On or Off?

    
respondido por el Danijel 17.08.2015 - 10:13
1

Lo resolví agregando

<?php header ("Connection: close"); ?> 

en file.php situado bajo wp-admin / include

    
respondido por el hashtagerrors 14.11.2016 - 06:05
0

Me encontré con el mismo problema y traté de hacer una búsqueda en google y se me ocurrieron tantas sugerencias técnicas que ni siquiera podía comenzar, ya que no soy experto en tecnología. Me encontré con un artículo donde una blogger dijo que contactó con su servidor de alojamiento y que cambiaron la versión de PHP. Puede o no funcionar para mí, pero lo iba a intentar.

Solo que no sabía cómo hacerlo y simplemente me salí con la atención al cliente y, básicamente, lo que hizo fue aumentar mi ancho de banda. Todavía no pude subir. Le dije que en la página de agregar biblioteca de medios decía que el tamaño máximo de archivo de carga era de 2 MB. Pero no fue hasta que actualicé la página que se inició el cambio y vi que mi tamaño máximo de archivo de carga era de 256 MB. ¡Después de eso pude subir fotos muy bien!

    
respondido por el user77871 17.08.2015 - 08:45
0

Resolví esto, eliminando libapache2-mod-php5filter:

apt-get remove libapache2-mod-php5filter

y la instalación de libapache2-mod-php5:

apt-get install libapache2-mod-php5
    
respondido por el Jo Smo 11.11.2016 - 10:11

Lea otras preguntas en las etiquetas