Solución de problemas de un sitio de red que muestra una página en blanco [cerrado]

4

Tengo una instalación de Wordpress en modo de red, con subdominios.

sitex.example.com está mostrando una página en blanco, sin nada en el código fuente.

Otros sitios de red se muestran bien.

Cambié el nombre del tema que estaba usando el sitio, pero no respondió a Twenty Twelve.

Un comprobador de respuesta del servidor mostró que el sitio está produciendo un código de respuesta 200.

Entré en el Administrador de red y cambié el nombre de sitex a sitey, pero sitey.example.com también produjo una página en blanco.

Verifiqué .htaccess y contiene el siguiente código:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]

Entré en mi cPanel de alojamiento y confirmé que todavía tengo mi subdominio comodín, y no tengo un subdominio manual para sitex en cPanel.

Regresé a Network Admin, modifiqué la configuración del sitio y configuré Template & Hoja de estilo a veinte doce, pero esto no hizo ninguna diferencia.

Estoy perdido.

No sé qué más podría estar causando esto.

¿Usted?

ACTUALIZAR

Si activo la depuración, recibo lo siguiente:

  

Advertencia: incluya (/.../ wp-content / advanced-cache.php)   [function.include]: no se pudo abrir la transmisión: no existe tal archivo o directorio   en /wp-settings.php en la línea 65

     

Advertencia: include () [function.include]: error al abrir   '/.../wp-content/advanced-cache.php' para inclusión   (include_path = '.: / usr / lib / php: / usr / local / lib / php') en /wp-settings.php   en la línea 65

     

Aviso: ¡wpdb :: escape está en desuso desde la versión 3.6! Utilizar   wpdb :: prepare () o esc_sql () en su lugar. en   /.../wp-includes/functions.php en la línea 2913

     

Advertencia: session_start () [function.session-start]: no se puede enviar la sesión   limitador de memoria caché - encabezados ya enviados (la salida comenzó en   /.../wp-settings.php:65) en   /.../wp-content/plugins/nivo-slider/nivo-slider.php   en la línea 10

    
pregunta Steve 06.02.2014 - 12:33

3 respuestas

0

Red inhabilitado un montón de complementos. Estos complementos se estaban ejecutando en el sitio del problema. Después de esto, el problema desapareció.

    
respondido por el Steve 10.03.2014 - 04:01
2

El .htaccess no tiene la información para el almacenamiento en caché, así que borre la memoria caché, desactive la red tanto su complemento de almacenamiento en caché como el complemento deslizante de nivo. Si está presente, elimine la configuración para habilitar el almacenamiento en caché en wp-config también.

¿Se carga /wp-admin.php para ese blog en este momento?

Si no, usando phpmyadmin ingrese a wp_blogid_options para ver qué se está cargando. Puedes borrar esas opciones y ver si el blog se carga.

    
respondido por el LPH 11.02.2014 - 13:28
2

Desactive el complemento Slider de Nivo para confirmar que esta es la fuente del error session_start. Esto definitivamente causaría una página en blanco. Estoy viendo la fuente del complemento y no hay ninguna función session_start, por lo que es un poco extraño. ¿Su plugin está actualizado?

Como el error dice "los encabezados ya enviados (la salida comenzó en /.../wp-settings.php:65)". Esto me lleva a creer que hay una instancia en caché de session_start que está causando un conflicto. Con suerte, resolver el problema con el inicio de sesión le permitirá seguir usando el caché si está funcionando correctamente.

Inicio de sesión

La función session_start debe ejecutarse antes que cualquier otro código. Específicamente, debe ejecutarse antes de que se publique el DOCTYPE y otra información del encabezado. La única forma que conozco de ejecutar session_start a través de WordPress es enlazar a init (o admin_init si su complemento se ejecuta en el PC de administración).
add_action('init', 'your_session_starting_function');

Otro complemento que use el enlace de inicio podría causar un conflicto si se ejecuta antes de que comience la sesión.

Solucionar errores de caché

Verifique su wp-config.php y, si existe, deshabilite o elimine la línea define( 'WP_CACHE', true ); . No se limite a ponerlo en falso.

Si está usando un complemento de caché como wp-cache, asegúrese de deshabilitar el caché. Si está utilizando un complemento de minify, desactive la minificación.

    
respondido por el iyrin 11.02.2014 - 22:11

Lea otras preguntas en las etiquetas