Habilitando SSL en wordpress resulta en 404

2

Estoy intentando forzar el inicio de sesión y la administración de ssl pero no funciona.

He intentado pasar por el tema de seguridad que no funcionó. Luego intenté hacerlo manualmente modificando mi wp-config.php para incluir:

define('FORCE_SSL_LOGIN', true);
define('FORCE_SSL_ADMIN', true);

Sin embargo, cuando voy a mysite / wp-admin obtengo:

  

La URL solicitada / wp-admin / no se encontró en este servidor.

     

Además, se encontró un error 404 No encontrado al intentar usar un ErrorDocument para manejar la solicitud.

Sacar esas dos líneas restaura la funcionalidad. Estoy usando la última versión de wordpress y tengo la estructura de enlace predeterminada.

¡Gracias por tu ayuda!

    
pregunta user1357015 21.05.2014 - 15:59

1 respuesta

4

Tuve exactamente el mismo problema y la solución para mí fue agregar estas líneas a /etc/apache2/sites-enabled/default-ssl.conf , que es el archivo de configuración de mi sitio web habilitado para SSL:

        <Directory /var/www/html/>
                AllowOverride All
        </Directory>

Por supuesto, esto asume DocumentRoot /var/www/html . Cambie en consecuencia si es diferente en su configuración.

Lo que pasa es que Wordpress usa las reglas .htaccess para procesar las URL y para que funcionen, AllowOverride All debe estar en el archivo de configuración del servidor.

En mi situación, la configuración para las variantes sin SSL y habilitadas para SSL estaba en archivos separados. La configuración no SSL tuvo AllowOverride All todo el tiempo, por lo que todo funcionó bien. Una vez que habilité el SSL, el otro archivo de configuración entró en juego y no tenía la configuración requerida AllowOverride All .

    
respondido por el Nick 24.07.2015 - 17:58

Lea otras preguntas en las etiquetas