El editor visual se congela en el texto resaltado desde 4.3

3

Desde que actualicé mi sitio web a 4.3, mi editor visual se está congelando cada vez que trato de resaltar un fragmento de texto, o incluso colocar mi cursor en algún lugar al azar. Esto solo parece estar sucediendo en el texto contenido dentro de una tabla HTML. Cuando abro la pestaña de la consola en Chrome, aparece el siguiente error una y otra vez:

    Uncaught RangeError: Maximum call stack size exceeded -- tinymce.min.js?ver=4203-20150730:7

Por recomendación de la gente de los foros de WordPress, ya intenté deshabilitar todos mis complementos, borré el caché de mi navegador y mi caché de Cloudflare, y cambié los temas a Twenty Twelve. Nada parece ayudar.

Incluso hice un subdominio e instalé una copia nueva de WordPress para probar si mi instalación de WordPress no funciona. No Lo mismo sucede incluso en un sitio web completamente nuevo que se ejecuta en 4.3.

También tengo otro sitio web en el mismo host pero todavía no lo he actualizado a 4.3, y todo funciona sin problemas como siempre. Sin congelación alguna.

Otra cosa que noté es que el uso de la CPU en mi PC aumenta a 60-70% cuando ocurre este error, y luego vuelve a la normalidad 2-5% cuando se descongela. También actualicé recientemente a Windows 10, si eso es importante.

Para replicar este error, copie el código de la tabla HTML a continuación y péguelo un par de veces en una nueva publicación, lo suficiente para que pueda desplazarse por la página. Luego intente desplazar la página en el Editor visual con la rueda del mouse y, al hacerlo, intente seleccionar un fragmento de texto. Esto sin excepción congela mi pantalla por 4-5 segundos.

<h3>Title</h3>
<table>
<tbody>
<tr><td><p>Nulla ac vehicula nunc. Sed sed maximus lectus, a cursus ligula. Aliquam enim lacus, mollis quis vestibulum et, imperdiet et enim. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Curabitur eget gravida est, a vehicula tortor. Curabitur aliquam lorem justo, vitae maximus metus porttitor vel. Aliquam neque mauris, posuere a mauris sit amet, ullamcorper accumsan velit.</p><p>Aenean vitae condimentum lacus. Vivamus sit amet velit quis lectus dapibus laoreet. Fusce ultricies aliquet arcu ac lacinia. Vivamus a erat ut erat ornare bibendum vel vitae velit. Vestibulum ut tellus quis magna luctus scelerisque pulvinar sit amet orci. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. In malesuada ligula in ante pharetra, id euismod est tempor.</p></td></tr>
</tbody>
</table>

¿Alguna idea de qué podría estar causando esto?

EDITAR: Solo probé en un par de otras computadoras solo para descartarlo, y sucedió en cada una de ellas. ¿Es un problema causado por el almacenamiento en caché tal vez? Estoy usando CloudFlare, pero ya purgué archivos varias veces. Algunas personas que están experimentando problemas similares dijeron que la actualización de PHP a 5.4 ayudó, pero ya estoy ejecutando esa versión.

EDITAR: completó un informe de error en enlace Parece ser un problema con el propio TinyMCE.

    
pregunta Dan 29.08.2015 - 21:22

0 respuestas

Lea otras preguntas en las etiquetas