¿Límite de carga de medios de Wordpress?

2

He realizado numerosos sitios WP, he escrito mis propios complementos, he ejecutado mi propio servidor, etc.

Pero no he visto esto antes. Acabo de instalar un 4.7.1 nuevo e instalé el tema de Proto y todos sus complementos.

Cuando fui a agregar archivos de medios, obtuve:

Maximum upload file size: 2 KB.

Desactivé todos los complementos uno por uno ... sin dados. Mi límite de memoria de PHP se establece en 256 MB para esta instalación a través de wp_config.php.

Al activar el límite de 2 KB no se obtuvieron resultados.

¿Alguien ha visto esto antes o sabe cómo arreglar este límite?

    
pregunta lilbiscuit 17.01.2017 - 16:04

4 respuestas

5

Tres cosas que debes revisar.

upload_max_filesize , memory_limit y post_max_size en el archivo de configuración php.ini exactamente.

Todos estos tres ajustes limitan el tamaño máximo de datos que puede enviar y manejar PHP.

Normalmente, post_max_size y memory_limit deben ser más grandes que upload_max_filesize .

Esta es la función en WordPress que define la constante que viste:

File: wp-includes/media.php
2843: /**
2844:  * Determines the maximum upload size allowed in php.ini.
2845:  *
2846:  * @since 2.5.0
2847:  *
2848:  * @return int Allowed upload size.
2849:  */
2850: function wp_max_upload_size() {
2851:   $u_bytes = wp_convert_hr_to_bytes( ini_get( 'upload_max_filesize' ) );
2852:   $p_bytes = wp_convert_hr_to_bytes( ini_get( 'post_max_size' ) );
2853: 
2854:   /**
2855:    * Filters the maximum upload size allowed in php.ini.
2856:    *
2857:    * @since 2.5.0
2858:    *
2859:    * @param int $size    Max upload size limit in bytes.
2860:    * @param int $u_bytes Maximum upload filesize in bytes.
2861:    * @param int $p_bytes Maximum size of POST data in bytes.
2862:    */
2863:   return apply_filters( 'upload_size_limit', min( $u_bytes, $p_bytes ), $u_bytes, $p_bytes );
2864: }
    
respondido por el prosti 17.01.2017 - 16:48
1

Intente pegar este código a continuación en todo .htaccess en la raíz de la carpeta:

Options -Indexes
php_value upload_max_filesize   1000M
php_value post_max_size         1000M
php_value max_execution_time    300
php_value max_input_vars        1600
    
respondido por el user111587 23.01.2017 - 16:21
0

Tuvo el mismo problema con las nuevas instalaciones esta semana. Debe establecer los límites de carga en su php.ini, si está en un servidor compartido debe crear un archivo llamado .user.ini y luego pegar el código a continuación

upload_max_filesize = 64M
post_max_size = 64M
max_execution_time = 300
    
respondido por el decoder88 30.01.2017 - 15:33
0

Hay un complemento "Tamaño máximo de carga" que te permitirá aumentar fácilmente el tamaño de las cargas. Bastante ligero. Consulte enlace

    
respondido por el Rick Hellewell 30.01.2017 - 21:32

Lea otras preguntas en las etiquetas