Redireccionamiento no deseado en el área de administración

3

Tengo un comportamiento extraño en mi backend. Esto es posible debido a la forma en que se encuentra mi WordPress.

Lo instalé en un VirtualBox, usando Ubuntu del repositorio estándar (es decir, apt-get install wordpress). Se encuentra en /var/www/ por defecto. El mashine virtual se asigna a una subcarpeta de la página web de mi institución. Llamémoslo www.institution.com/stuff/wordpress .

La mayoría funciona bien, puedo iniciar sesión en el backend, crear páginas, etc. Pero, si realizo cambios en Configuración / General y hago clic en el botón "Guardar cambios", aparece un "Error: NotFound". Los cambios se guardan, pero WordPress intenta enviarme a

www.institution.com/wp-admin/options-general.php?settings-updated=true

pero esto tiene que ser

www.institution.com/stuff/wordpress/wp-admin/options-general.php?settings-updated=true

(falta /stuff/wordpress )

Ambos, la "URL de la dirección de WordPress" y la "URL del sitio" están configurados en "www.institution.com/stuff/wordpress". Pero obviamente, esto no es suficiente.

¿Alguien tiene una idea de lo que está mal con mi WordPress?

    
pregunta Keelan 25.02.2013 - 21:15

1 respuesta

2

Lo resolví con la ayuda de uno de mis colegas agregando las siguientes líneas en wp-config.php:

$_SERVER['HTTP_HOST'] = $_SERVER['HTTP_X_FORWARDED_HOST'];
$_SERVER['REQUEST_URI'] = '/stuff/wordpress' . $_SERVER['REQUEST_URI'];
$_SERVER['SCRIPT_NAME'] = '/stuff/wordpress' . $_SERVER['SCRIPT_NAME'];
$_SERVER['PHP_SELF'] = '/stuff/wordpress' . $_SERVER['PHP_SELF'];
$_SERVER['REMOTE_ADDR'] = $_SERVER['HTTP_X_FORWARDED_FOR'];
    
respondido por el user28001 26.02.2013 - 13:02

Lea otras preguntas en las etiquetas